Giobe®2000
Pagina creata il 15/07/2009 [4518 giorni fa]
Tutorial Assembly by Giobe®2000
Sezione Assembler - Home Page Sezione Assembler PsPAD/Configurazione [4 di 4] [28 di 51] 
1. Leggi subito! 2. Per chi parte da zero 3. Cos'è 4. Come si installa 5. Come si usa 6. Apri shell DOS dal Sito
7. Adatta shell DOS 8. Lancia EXE on-line 9. Scarica ASM 10. Caratteri strani 11. Prima compilazione 12. Download
11. Nuovo Ambiente Assembler - Configurazione di PsPAD [1 di 4] [2 di 4] [3 di 4] [4 di 4]
Istruzioni per configurare l'editor PsPAD 

 8. Cominciamo dal primo, attivabile direttamente, con F9, oppure a partire dal menu in alto, via File > Apri con > [!] Expert GUIDE Reader, oppure cliccando sulla prima iconcina posta in alto a destra, sotto il menu dell'editor; ad esso ho deciso di affidare la gestione di favolosi archivi di informazioni tipiche dell'assembly con l'aiuto del programma Weg_2.15 [Copyright Dave Pearson], uno straordinario gestore di archivi di dati (Expert Guide Reader for Windows) già configurato per vedere a questo lavoro; le mie scelte finali sono le seguenti:

Configurazione di PSPad - Comando Expert Guide Reader

 9. Fissiamo poi le scelte finali per il secondo comando, attivabile direttamente con Alt + F9, oppure a partire dal menu in alto, via File > Apri con > Esegui, oppure cliccando sulla prima iconcina posta in alto a destra, sotto il menu dell'editor, studiato per per mandare in esecuzione il file eseguibile EXE o COM, supposto già creato e disponibile: 

Configurazione di PSPad - Comando Esegui

 10. Il terzo comando, tra i 4 possibili, è programmato per compilare il sorgente ASM e per vedere il risultato in esecuzione con un comando solo; come già premesso (a causa dei limiti di PSPad nell'eseguire i comandi esterni) questo servizio (pur garantito con successo) è meno efficiente di quello analogo che propone questi eventi in sequenza (compilando prima con Ctrl F9 e vedendo poi con Alt F9), perchè non gestisce il riquadro dei messaggi, e quindi è poco pratico!! Ciononostante fa bene il suo lavoro e, a piacere, può essere attivato direttamente, con Shift + F9, oppure a partire dal menu in alto, via File > Apri con > Compila ed Esegui, oppure cliccando sulla prima iconcina posta in alto a destra, sotto il menu dell'editor:   

Configurazione di PSPad - Comando Compila ed esegui

 11. Per il quarto e ultimo comando, non è previsto un tasto diretto e può essere attivato cliccando sulla prima iconcina posta in alto a destra, sotto il menu dell'editor, oppure a partire dal menu in alto, via File > Apri con > Debug; esso è programmato per attivare automaticamente una fase di debug dell'eseguibile (se disponibile, cioè se la fase di compilazione è stata portata a termine senza errori) all'interno di una shell dos:

Configurazione di PSPad - Comando Debug

 12. Poichè l'editor PSPad consente anche di mettere in esecuzione direttamente comandi o eseguibili dal prompt del Dos, ho pensato di fornire un esempio pronto per provarlo; esso si attiva cliccando sulla terza iconcina posta in alto a destra:

Editor PsPad - Prompt del DOS

oppure a partire dal menu in alto, via Strumenti > Linea di comando:

Editor PsPad - Prompt del DOS

 Per il collaudo ho predisposto un opportuno file batch, istruendo con esso la casella di messa a punto con le seguenti informazioni:

Configurazione di PSPad - Gestore del Prompt del DOS

 13. Può essere utile, per finire, presentare ai miei curiosi visitatori le variabili predefinite utilizzate dall'editor PSPad, molto utili per alcune fasi di messa a punto; ad esse si accede a partire dal menu in alto, via Configurazione > Variabili predefinite; le allego in sequenza:

Configurazione di PSPad - Variabili del programma

Configurazione di PSPad - Variabili del programma

Configurazione di PSPad - Variabili del programma

Configurazione di PSPad - Variabili del programma

La guida alla configurazione di PSPad termina qui; per tua comodità ho predisposto una copia PFD da leggere, stampare e scaricare a tuo piacimento:

Scarica il documento PDF relativo a questa GUIDA
[Scaricato 2388 volte]

Cliccando sulla freccia a destra (nella barra orizzontale qui sotto) puoi proseguire con la descrizione delle tecniche che ho utilizzato per configurare le rimanenti versioni d'accesso; se invece sei interessato alle istruzioni per il corretto utilizzo di questo editor puoi saltarci direttamente utilizzando il link seguente:

Salta alle istruzioni d'uso di PsPAD in Ambiente Assembler
Torna alla pagina principale dell'Ambiente Assembler
Pagina Precedente Assembler Pagina Successiva PsPAD/Configurazione [4 di 4]   VERIFICA la validità della pagina!! Torna alla Home della Sezione Assembler
28 di  51
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
NUOVO
AMBIENTE
ASSEMBLER
NB: Leggi subito!!|Per chi parte da zero|Cos'è l'Ambiente Assembler
Come si installa l'Ambiente|Come si usa l'Ambiente [Guida Utente]
Come aprire una finestra DOS dal Sito|Come si ottimizza una finestra DOS
Come lanciare eseguibili on-line|Come salvare i sorgenti ASM da Web
Caratteri "strani" nei sorgenti ASM|Guida alla prima compilazione
Area di Download e considerazioni conclusive
Accedi al TUTORIAL ASSEMBLY »  Prefazione|CAP 1|CAP 2|Schede
Accedi alla Palestra Apprendisti|Accedi alla Palestra Esperti
Analizza le Procedure di Giobe.LIB|Analizza le Macrositruzioni di Giobe.MAC
Risorse Software »  Area Comunicazione BIOS|Funzioni BIOS|Funzioni DOS
Risorse Hardware »  Raccolta Indirizzi Base|Registri delle Periferiche|Progetti ASM
Risorse Generali »  Download Manuali ASM|Info|Indice GENERALE
Home
Pascal|Manuali|Tabelle|Schede|Pubblicazioni
Tutorial Assembly|Palestra Assembler
Nuovo Ambiente Assembler
Aggiungi Giobe®2000 ai preferiti  
Motore
Ricerca
  Rendi Giobe®2000 pagina di Default
Copyright ® 2001-2012 -  Studio Tecnico ing. Giorgio OBER
Tutti i diritti sono riservati